Home

Home | About Us | Contact Us | Privacy Policy
Copyright © 2017 SMPCS

Home TPM for OS X TPM for Windows Downloads Support

TPM for OSX

Introduction
Features
Screen images
FAQ
Download Trial
Purchase TPMX

Can TPMX run on an old Mac running OS 9.1?

Teacher's Personal Markbook for OS X requires OS X 10.4.11 (Tiger) or newer. The version 10.6.x (Snow Leopard) is the minimum recommended, although TPMX still runs on Tiger and Leopard. Teacher's Personal Markbook for OS X works on Mountain Lion and Lion. An Intel processor is also required, although if you have PowerPC processor Mac please contact Technical Support to inquire about the possible availability of a PPC version.